Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Stuck at Initial Configuration

Nacer Feb 15, 2019 05:01AM PST

Hi,

I just installed Fastvue syslog server. When I try to access http://localhost:47279, I only see "Initial Configuration". Can not access some kind of console.

Somehow, save configuration button works. I changed listening port to 50514 (router side and syslog server side) and seeing TCP activity on TCPView.

And there is no log text in C:\ProgramData\Fastvue\Syslog Server\Logs

I tried i.e, chrome and firefox. Windows 7 64 bit with latest java and .net installed. And two different PC. Tried reinstall few times. Same all...

Is there any solution?


Up 0 rated Down
Leo Feb 15, 2019 06:25AM PST FASTVUE Agent
Hello,

Thank you for contacting us. We have an article that covers this type of issue.
http://syslog.fastvue.co/customer/en/portal/articles/2636117-no-syslog-data-received-or-no-log-files-being-created

It sounds like you have tried different web browsers, so the most likely culprit is either a firewall rule or port conflict.

Please let me know if you have any further questions or issues.

Regards,
Leo
Up 0 rated Down
Nacer Feb 15, 2019 08:03AM PST
Hi Leo.

I don't think there is a port conflict.
I can receive data from 514 or 50514 with other syslog server applications.
Also I can see data I revived on TCPView software which shows 10 MB of data accepted since I posted first message.

And also as i said can not pass first Initial Configuration page.

C:\ProgramData\Fastvue\Syslog Server dir conrains onlu
Arcive (Dir)
Logs (Dir)
SyslogServer.log

And nothing in those directories. I saw some videos about resetting password and there was some js files in C:\ProgramData\Fastvue\Syslog dir. But there is non in mine. May be this is ti problem?

Thank you...



Up 0 rated Down
Leo Feb 15, 2019 08:05AM PST FASTVUE Agent
Hello,

It sounds like some rights are not working correctly if all other settings are working. Can you re-install the software(Run as Administrator)? Once installed can you also launch the software link from My Programs using the "Run as Administrator"?

If you open the software in Chrome, you should be able to see everything.

Regards,
Leo
Up 0 rated Down
Nacer Feb 17, 2019 05:03PM PST
Hello Leo,

Thank you for advice.
I tried 5 windows 7 PCs and only one setup worked without problem.
As I said before setup process can not create .json files somehow.

I copied .json files to other pcs and run setup again. After that they started to work.

Just for your information. :)

By the way, do you have any solution to sign these log files with OpenSSL CA with time stamp for legal proceedings?


Thank you.
Up 0 rated Down
Fastvue Feb 17, 2019 05:11PM PST FASTVUE Agent
Thanks for the info. I'm glad you were able to get the software working by manually creating in the .json files. Strange that you had to do that. It must be a permission issue on the machines and the directories you're trying to get the software to write to.

We do not have a solution that signs the files with OpenSSL CA with timestamps.

We do have a new version (v2.0) which we are about to release. I'll send you the information in a separate email. It includes TCP support and should resolve most of the browser UI issues we've seen in the past.

If you're interested, we've also published some API documentation:
https://docs.fastvue.co/fastvue/syslog/api/2.0/

And open-sourced the user interface code:
https://github.com/Fastvue/fastvue-syslog-ui

I hope this helps. Let me know how you go!

Cheers!
Scott

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)

Contact Us

  • Post a Public Question
  • Email Us
support@fastvue.co
http://assets2.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete?b_id=15094